Cisco SG300-20 Switch First Look

Today I received my Cisco SG300-20 network switch – part of the new lab environment I am putting together at home. It’s a 20 port gigabit switch with layer 3 functionality. The unit itself looks very nice as you might expect from a Cisco switch and importantly for me is passively cooled so no noise!

Let us take a quick look at the unit…

Cisco SG300-20 Datasheet Link

Cisco SG300-20 Switch Visio Layout - Front and Back

 

As you can see we have 18 ports of gigabit Ethernet over traditional copper UTP/STP with the final two ports offering the same OR the use of 2 SFP (small form-factor pluggable) ports. On the rear we have a single power connect (C14) along with the classic 9 pin serial console port. The unit has rack mounting points however my unit will just sit on top of the micro servers I’ve purchased so this isn’t something I’ll be making use of at this time.

How about we take a look inside the unit – after all the first thing you do with any new kit is take it apart!

The first picture shows the unit with the main cover removed. We see the power unit, front panel LED module along with the main PCB.

Cisco SG300-20 Switch Internals

 

Now for a closer look at the main PCB.

Cisco SG300-20 Switch Internals

Cisco SG300-20 Switch Internals

Cisco SG300-20 Switch Internals

 

I have to say part of me wants to see all those heatsinks neatly aligned but who am I to question PCB design?

Once I had put the unit back together I connected the serial lead to an adapter I have (serial to USB) and connected to my computer. Unfortunately this happened…

Blue Screen Crash - asmthub3.sys

 

As you can imagine I was pretty annoyed and even worse the official download site for the driver was undergoing maintenance so I couldn’t even grab an updated version. I decided I’d just connect the switch to my existing home network and configure it that way. The instructions indicated the switch would have an IPv4 address of 192.168.1.254 however mine came up with a DHCP address. Once I had the address from my router I launched PuTTY and tried to connect over SSH, and then this happened…

PuTTY Network error: Connection refused

 

Starting to get the feeling some higher power doesn’t want me to connect to this switch! Thankfully the HTTP interface was active and did allow me to connect.

HTTP Switch Configuration

 

The default logon credentials are cisco/cisco for the username and password. The interface prompts you to update the password which I did and it even provides a password strength meter. Now I would say I don’t put much faith in these as they are entirely dependent on the coding behind so put your security hat on and make sure you configure a complex password.

HTTP Switch Configuration - Change Password

 

Next I updated the firmware to the latest stable version available from Cisco, currently 1.4.2.04.

HTTP Switch Configuration - Upgrade Firmware

HTTP Switch Configuration - Upgrade Firmware

 

Once you have loaded the firmware onto the switch you need to make sure you select it to be loaded at the next boot.

HTTP Switch Configuration - Set Active Firmware Image

 

Lastly I enabled SSH so I could configure the switch from the command line.

HTTP Switch Configuration - Enable SSH

 

Having checked my SSH session established successfully I made sure to save my running configuration to the startup configuration file. There is a lot more configuration required but that can wait for the rest of the lab equipment to arrive. I’m quite excited to see what I can do with this device and it will certainly help me brush up on some of my Cisco skills which aren’t as sharp as they were due to the fact we have a separate network team at work.

I shall no doubt be writing further posts on the switch and use of it in my lab so look out for more.

Leave a Reply

This site uses Akismet to reduce spam. Learn how your comment data is processed.