HP 3PAR Simulator Deployment on VMware Workstation

Having fleshed out the HP documentation for deploying the 3PAR simulator on VMware ESXi I decided to take the plunge and do the same for the VMware Workstation deployment.

First off I will be using some material from the previous post as once the deployment and configuration of Workstation is complete the remaining steps are the same.

With that said, let us begin.

System Requirements

The 3PAR Simulator requires a VMware ESXi 5.x or a VMware Workstation 9 or 10 setup. The simulator configuration
requires deploying three VMs; two VMs simulating the cluster nodes, a third VM to simulate the enclosure and private
network configuration to enable communication between the three VMs.
The minimum system resources required for each VM are:

  • One virtual CPU (single core)
  • Three virtual NICs
  • 2GB RAM
  • 50GB disk space (full or thin-provisioned)

Note – If you are going to deploy the 3PAR Simulator with Remote Copy over IP (RCIP) the cluster node VMs will require more resources. HP suggest 4 GB of RAM is needed for each cluster node.

Step 1 – Deploying the Cluster Nodes

The first step is to deploy the OVF package to our virtual environment. The simulator comes with two OVF files, one for the cluster nodes and the other for the enclosure node. We will start by deploying the cluster node OVF.

Open Workstation and work your way through the ‘Deploy OVF Template’ wizard. I have taken screenshots from the Workstation interface for guidance.

  • Click to Open a Virtual Machine

VMware Workstation - Click to Open a Virtual Machine

  • Browse to the cluster node OVF

Browse to Cluster Node

  • Give the cluster node VM a name and pick a location for the VM files to be saved in then click ‘Import’. Use a sensible naming convention, for example I have named mine 3PARSIMCN01 (CN = cluster node)

Name Virtual Machine

  • Depending on the hardware you are using the import process may take a while to complete

Importing Virtual Machine

  • The next step is to deploy the second cluster node. You can either repeat the steps taken above for the first cluster node or you can leverage the ‘Clone’ option

VMware Workstation - Clone Virtual Machine

  • If you choose to clone the VM follow these steps

VMware Workstation - Clone Virtual Machine Wizard

  • Click to clone the current state of the VM

VMware Workstation - Clone Current State

  • We have two choices, either create a ‘Linked Clone’ or a ‘Full Clone’
    • Note – if you create a Linked Clone you MUST keep the original VM as a linked clone relies on this to work. It is essentially a differencing technique that references the original and writes any changes between these two clones to it’s own set of files. This allows us to minimise disk space utilisation, a Full Clone is a complete copy that does not  require the original in any way and will function even if the original VM is deleted

VMware Workstation - Create a Linked Clone

  • Give the second cluster node a name and choose a location for the VM files – in this instance I will append 02 to help me identify the second cluster node

VMware Workstation - Name Clone

Step 2 – Deploying the Enclosure Node

This process is identical to deploying a cluster node – open Workstation and work your way through the ‘Open a Virtual Machine’ wizard selecting the enclosure node OVF file.

As above make sure you pick a sensible name for the VM to help you identify it. For example I chose 3PARSIMEN01 (EN = enclosure node)

VMware Workstation - Name Virtual Machine

Step 3 – Configuration

Now that we have our VMs deployed it’s time to start configuring. Make sure you complete the steps below BEFORE you power on the VMs.

VM Configuration

To begin with, if you intend to deploy a second simulator and link the two to test things like Remote Copy over IP the now is the time to increase the RAM allocated to the cluster nodes. HP recommend at least 4GB of RAM when utilising the RCIP feature.

Network Configuration

The cluster nodes each have 3 NICs and each has a specific use and requirement.

vNIC1

  • The first vNIC is for management – this is what we will use to connect over SSH, the 3PAR Management Console and any other management tools we may wish to use. Ensure you connect this vNIC to a Virtual Network that has access from your desired management station. This could be the machine you are running Workstation on or another VM.

vNIC2 (optional config)

  • The second vNIC is used for Remote Copy over IP and is dedicated to this purpose only. The second vNIC should only be configured on the cluster nodes, there is no need to configure the enclosure node vNIC. If you do not intend to use the RCIP feature then you can skip configuring this adapter.

vNIC3

  • The final vNIC is used to connect the 3 virtual machines which make up the simulator. This is done on a private Virtual Network within Workstation.

Virtual Network Configuration

  • Open Workstation and select the first cluster node you deployed

VMware Workstation - Select Cluster Node

  • Click Edit Settings
    • Click on Network Adapter 3

VMware Workstation - Edit Virtual Machine Network Settings

  • Click the ‘LAN Segments’ button and click ‘Add’

VMware Workstation - Global LAN Segments

  • Give the LAN Segment a name, for example I chose 3PARLABNetwork

VMware Workstation - Global LAN Segments

  • Now click on the ‘LAN Segment’ radio button and select our newly created LAN Segment

VMware Workstation - Select LAN Segment

  • Click OK to close the Settings menu

Now complete the above steps for the second cluster node and for the enclosure node – make sure all 3 virtual machine ‘Network Adapter 3’ settings are configured to ‘LAN Segment’ and that your newly created segment is chosen.

Next we need to configure the Management network on vNIC1 for our Cluster nodes. It is this interface we will use to connect our 3PAR management console or SSH session.

  • Open Workstation and select the first cluster node you deployed

VMware Workstation - Select Cluster Node

     

    • Click Edit Settings
      • Click on ‘Network Adapter’ and select the ‘Host-Only’ optionVMware Workstation - Edit Network Settings
    • Click OK
    • Host only networking is facilitated through a virtual network adapter created on your computer when you installed VMware Workstation.As you can see below I have an adapter called VMware Network Adapter VMnet1 – it is this adapter which will be used for ‘Host-only’ communication.

      Host Network Connections

    • Return to Workstation and click the ‘Edit’ menu and open the ‘Virtual Network Editor’VMware Workstation - Open Virtual Network Editor
    • We need to note the IP address information configured by Workstation for DHCP issuance on VMnet1VMware Workstation - Virtual Network Editor
    • In my case VMnet1 has a Type of ‘Host-Only’, DHCP is enabled and the subnet address is 192.168.252.0 /24
      • We can check the IP allocated to this network adapter on our host machine using ipconfig or the PowerShell command Get-NetIPAddress -AddressFamily ‘IPv4’ -InterfaceAlias ‘VMware Network Adapter VMnet1’
        • IPCONFIG Output –
      • Get-NetIPAddress -AddressFamily ‘IPv4’ -InterfaceAlias ‘VMware Network Adapter VMnet1’ Output

      As you can see I have an IP address on the correct subnet – it is important to know what subnet our management network is using so we can configure an appropriate IP address during the simulator configuration.

      Simulator Configuration

      Make sure you have the following information to complete the configuration –

    • HP 3PAR StoreServ storage system name, an alphanumeric name up to 31 characters.
    • IP address, subnet mask and Gateway IP address. The IP address must be a statically assigned address and will be chosen from the range identified above
    • Gateway IP address
    • NTP server IP address (optional)
    • DNS server IP address (optional)

     

    • Power on your simulator VMs – depending on your hardware they may take a while to complete the boot process.Once the VMs have started open the console to your enclosure VM – remember there is only one of these. You can tell you are on the correct VM as the CLI prompt will show ‘esdhost login’ –Power on ESD Host 
    • Logon using the following credentials –
      • Username – root
      • Password – root
    • Enter the command createcages

    createcages
    As you can see a number of options are available to us. This is where we get to decide how our virtual simulator disk layout will look, review the options and pick one of your choice. I will select option 2 –

    • 4 cages, 48 HDDs 1 DCN1 cage with 6 FC drives and 6 SSD drives 2 DCS2 cages with 6 FC drives and 6 SSD drives each
    • Now that we have chosen a disk layout it is time to start the esd daemon. To do so, enter the command esd

    Choose disk layout and enter esd

    Now it is time to configure the cluster node VMs.

    Open a console for the first cluster node you deployed, logon to the node with the following credentials –

    • Username – console
    • Password – cmp43pd

    Logon to Cluster Node

    • Choose Option 1 – Simulator Cluster Node Configuration – you will be prompted to accept the license agreement
    • Enter 0 for the Node ID
    • Enter a serial number for the cluster node. HP provide two serial numbers – 1699678 or 1699679. Make a note of which serial number you choose – we will need this when configuring the second cluster node
    • Confirm your settings

    Configure Cluster Node

    • Choose Option 5 to Reboot the node – do this now

    Open a console for the second cluster node you deployed, logon to the node with the following credentials –

    • You will be prompted to confirm details a number of times – press c to continue on each
    • Verify the InForm OS versionsConfigure Cluster Node
    • Enter the InServ name for this arrayConfigure Cluster Node
    • Select regional settings and configure the date and timeConfigure Cluster Node

    Configure Cluster Node

    • Type c
    • Type yes
    • Complete the same steps as above but this time make sure to select 1 for the Node ID.
      • Note – it is VITAL that you enter the same serial number for Node 1Configure Cluster Node

        • Choose Option 5 to Reboot the node – do this now

        Once both nodes have rebooted logon to the first cluster node.

        • Choose Option 2 – Out Of The Box Procedure

        Configure Cluster Node

    • Password – cmp43pd
    • Username – console
    • Note – this process may take a while
    • An SSL certificate will be generated – the system will present you with the Subject and SHA1 fingerprint, make a note of these for later verificationConfigure Cluster Node
    • The system will prompt you to configure IP address detailsConfigure Cluster Node
    • I have chosen to only use an IPv4 address. The system will prompt for an IP, subnet mask and gateway address. Remember we checked earlier what range our VMnet1 adapter was on? Well now is the time to set a static IP address in this range and remember this network does not have a default gateway so enter ‘None’ when promptedConfigure Cluster Node
    • I have chosen to use auto negotiationConfigure Cluster Node
    • Enter an NTP server IP if you have one – in my case I will leave this blank for now as my lab is not fully setup on this workstation
    • Enter a DNS server IP if you have one – in my case I will leave this blank for now as my lab is not fully setup on this workstation
    • Do not disable non-encrypted portsConfigure Cluster Node
    • Check your settings and confirm they are correct
    • The system will now complete configuration of the cluster nodes
    • You will be prompted to select a spare chunklet selection algorithm – I have chosen to use the minimal setting by entering MiConfigure Cluster Node
    • You will be prompted to Continue and then asked whether you wish to enable the CIM-based management API. I chose to enable this functionality

    Configure Cluster Node

    • After some scrolling the system will ask you to confirm your acceptance of the terms and conditions – do so now

    Configure Cluster Node

    That’s it!

    We are finished and can test functionality by opening the 3PAR Management Console and trying to connect. Of course you can ping the management IP you defined earlier to test basic connectivity exists –

    PING Test Connectivity

    Open the 3PAR Management Console and use the following credentials to connect –

    • Username – 3paradm
    • Password – 3pardata

    3PAR Management Console Logon

    • Assuming you have configured everything correctly you should be prompted with a certificate alert – remember we made a note of the certificate details earlier. Validate the certificate subject and SHA1 fingerprint.Accept the certificate and you will be connected to your brand new 3PAR simulator.If you need to shutdown the simulator the correct process is detailed below.

      Power Off the Simulator

      Gracefully shutdown the HP 3PAR Simulator by first shutting down the cluster nodes, then stop the esd daemon and shutdown the esd VM. Use the following steps:

    • Login to cluster node 0
      • Username –  3paradm
      • Password – 3pardata
    • Run the command – shutdownsys halt

     

    • Note – In certain cases, it might be necessary to power off the VMs using the Workstation client after issuing the command to shutdown the system.Once the cluster node VMs (node 0 and node 1) are powered down:
    • Login to the enclosure node
      • Username – root
      • Password – root
    • Run the command – esd stop
    • Once the daemon is stopped, issue the command –  shutdown –h 0

     

    Powering On the Simulator

    Start the enclosure VM first and then run the command esd – this will start the esd daemon. Remember there is only 1 enclosure node

     

    33 thoughts on “HP 3PAR Simulator Deployment on VMware Workstation

    1. Hi,

      I tried to install the same but getting vhbamod error and then node 2 i can see buffer I/O error. This starts to come after the Out of Box configuration are set. Did you faced anything like that?

      Regards

    2. It Is coming from the virtual machine, using the same config as you have stated. I have got the simulator with version 3.2.1. Which version of 3PAR simulator that you have?

      • I have both the previous and latest (3.2.1) simulator and I haven’t seen this issue yet on either. Have you tried a fresh install of all the VMs? If you take some screenshots and Tweet them to me I can take a look. What version of VMware Workstation are you running?

        Alex Bytes

        • I had tweeted you let me know if you need any more information, I am using VMware Workstation 10 and all the configs as you mentioned in your portal

            • Yes mailed you the screenshot of the error. Strangely though I am stuck here and have to get it work before the presentation to the client for getting the PO approved.

              • OK that’s very strange I haven’t received anything on my Twitter account in either a direct message or Tweet. If you can try again I may be able to assist – do you have another system you can try the install on? Hopefully we can get this issue resolved for you.

                Alex Bytes

                • I am going to install VMware workstation on Windows 2008 server and see if it works for me. Strangely it works till the server are added in cluster but when you do OOT for getting the storage from enclosure it gives all this strange errors. Did you installed in your laptop or any of the desktop servers of yours.

                  • Hi Sam,

                    My Workstation deployment is on a high end desktop however I tend to use ESXi to host my simulators as I have spare resources at work to allow me to do this. OK so you can join the two cluster nodes together to form the cluster? You’ve definitely initialised the enclosure node and created the disk and cages on it? It’s also important to ensure the virtual machine network adapters are setup correctly. I’m sure you’ve already check these things but it would be good to confirm.

                    Alex Bytes

                    • Alex,

                      It failed again with straight workstation installation then i installed VMware ESXi 5.5 and then tried to install the simulator on top of it, it still failed. I guess there is some issues with the simulator was getting “local_softirq_pending 08” error once the nodes are rebooted the first time. I have the version 3.2.1 simulator with me, let me know if you have tried that version and it is working for you.

                      Regards

                      • Hi Sam,

                        I’ve installed the 3.2.1 simulator without issue on Workstation and ESXi – perhaps your download is corrupt? It’s hard to know without sitting through the install myself but I’d suggest downloading again and trying a fresh installation. If that still doesn’t work try and Tweet some screenshots to me and I’ll take a look.

                      • Alex,

                        Tried it again with fresh download no luck, I can share the link of the download if you want you can give a try and let me know if that works for you. Please share your email id.

                        Regards,

                      • Hi Sam,

                        Simplest thing is to send me a Tweet or Direct Message on Twitter (@bytesizedalex). You can also send me some screenshots of the issue. Hopefully we can figure out what is causing this problem for you.

                        Alex

                      • OK something very strange has happened – I’ve reviewed this post and whole sections are out of order or jumbled around. not sure what happened but I can see some previous versions that look correct. I may have to restore this post, it could also be why you are having problems as you may have completed the steps in the wrong order. My apologies – going to try and sort this ASAP.

                        Alex

    3. Hello Guy,
      When i’m trying to access the cluster node, se below the error message i have :
      “The Inserv Simulator License has expired”

      • Hi Sudipta,

        You will have to contact your HPE representative – while there was a contact previously this avenue is no longer open to us. I know it’s a pain but contacting your account manager or local HPE representative is now the approved route for requesting access to the 3PAR simulator.

      • Hi Sudipta,

        I reached out to the HPE 3PAR product manager along with a few others to see what the current state of affairs is for the simulator. The good news is they are working on a public open version. They couldn’t give me a time frame for release but said to keep an eye out in the near future so fingers crossed people will have access to a version of the simulator soon.

        Alex

      • Hi Pramod,

        You will have to contact your HPE representative – while there was a contact previously this avenue is no longer open to us. I know it’s a pain but contacting your account manager or local HPE representative is now the approved route for requesting access to the 3PAR simulator.

      • Hi Pramod,

        I reached out to the HPE 3PAR product manager along with a few others to see what the current state of affairs is for the simulator. The good news is they are working on a public open version. They couldn’t give me a time frame for release but said to keep an eye out in the near future so fingers crossed people will have access to a version of the simulator soon.

        Alex

    4. Hi Alex,

      I am getting the same error Sam had: 47.276843 NOHZ: local_softriq_pending 08. It has nothing to do with the weird way your guide is out of order. Still is out of order though. Anyway, were you ever able to find what issue he could have been having?

      • Ah dear I’ve re-ordered the guide once already, something must be up with my site saving it. My apologies for the ordering I will try and get that fixed ASAP. As for the error I assume this is a fresh build with the latest publicly available simulator?

        • Yeah it is a fresh setup with the newest version. I’m guessing it’s something networking related. I’m still a bit green at that but I’ve tried it several different ways now. The only thing I can think of is that maybe it doesn’t like Workstation 12? I’m going to try and use workstation but build nested esxi hosts in a vcenter server environment and then I will try and implement it there and see what happens. I honestly don’t know.

          I’ve found some info on the HPE forums where people had a similar issue but whereas they were able to get a login prompt after the softirq thing, I can’t get a prompt. I have to force one, and then when I go to OOB, it just keeps asking me over and over if I want to continue. Regardless of whether I hit yes or no it just keeps asking. I’ll let you know if I find anything. Thank you for the guide though. It definitely helped me get going.

          Do you happen to have anything more about building the workstation networking environment from scratch using the 10.x.x.x private IP setups? Thanks again for the guide!

            • Yes. I see a lot of people use the 10 subnet and I’ve seen some answers to questions I’ve had saying that using 192.168 is going to cause me network problems. I don’t see how that could be the case but I’m wondering if 192 has caused you any issues before. I’ve also read things where they say that it makes absolutely no difference if you use 10 or 192. I’m trying to learn as much as possible but I feel like I still don’t know enough about networking to help myself. Every time I try and follow a guide for 3PAR or vsphere I get stalled out at a point that doesn’t really seem to be a place where anyone else has problems. The only thing I can think of is that I’m doing something wrong when it comes to using workstations network adapters and virtual network editor. Thank you again for your time.

              • Well it’s up to you how you define your RFC1918 private IP address range but I don’t think you should see any issues with the 192.168.*.* range if configured correctly. VMware Workstation automatically creates a number of virtual NICs on your machine and assigns subnets to them with DHCP ranges that should not conflict with the range you receive on your physical NIC(s). IF you like you could take some screenshots of your progress and where you get stuck and I’ll try and help you through it. I know it can be very frustrating tackling new subject matter but as they say ‘every day is a school day’.

                Alex

    Leave a Reply